Top.Mail.Ru
Персональный сайт учителя информатики Звездиной Веры Алексеевны

Понятная информатика,

или Давайте учиться дружно!

Решение задач по теме 9 предполагает знание цикла N раз (с заданным числом повторений) и аккуратности при выполнении. Не торопитесь!

TestEdu v1.21 - 2018 год Простейший циклический алгоритм, записанный на алгоритмическом языке
Ответами к заданиям являются слово, словосочетание, число или последовательность слов, чисел. Запишите ответ без пробелов, запятых и других дополнительных символов
Информатика 9 класс   |   Дата: 29.03.2019   |   Вопросов: 10   |   Автор: Звездина Вера Алексеевна
Вопрос № 1

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел s, к
s := 0
нц для к от 6 до 12
s := s + 10
кц
вывод S
кон

Бейсик
s = 0
FOR к = 6 ТО 12
s = s + 10
NEXT к
PRINT s
END

Паскаль
var s, k: integer;
begin
s := 0;
for k := 6 to 12 do
s := s + 10;
write (s);
end.

Введите ответ:
Вопрос № 2

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел s, к
s := 1
нц для к от 2 до 7
s := s + 100
кц
вывод S
кон

Бейсик
s = 1
FOR к = 2 ТО 7
s = s + 100
NEXT к
PRINT s
END

Паскаль
var s, k: integer;
begin
s := 1;
for k := 2 to 7 do
s := s + 100;
write (s);
end.

Введите ответ:
Вопрос № 3

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел s, к
s := 120
нц для к от 10 до 20
s := s - 10
кц
вывод S
кон

Бейсик
s = 120
FOR к = 10 ТО 20
s = s - 10
NEXT к
PRINT s
END

Паскаль
var s, k: integer;
begin
s := 120;
for k := 10 to 20 do
s := s - 10;
write (s);
end.

Введите ответ:
Вопрос № 4

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Бейсик
s = 0 n=12
FOR i = 1 ТО 10
s= s+n-i
NEXT i
PRINT S
END

Паскаль
var s, n, i: integer;
begin
s:=0; n:=12;
for i:=1 to 10 do
s:=s+n-i;
write (s);
end.

Алгоритмический язык
алг
нач
цел s, n, i
s:=0,
n:=12,
нп для i от 1 до 10
s:= s+n-i
кц
вывод s
кон

Введите ответ:
Вопрос № 5

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел s, k
s := 2
нц для k от 1 до 3
s := s * s
кц
вывод s
кон

Бейсик
DIM k, s AS INTEGER
s = 2
FOR k = 1 TO 3
s = s * s
NEXT k
PRINT s

Паскаль
ar s,k: integer;
begin
s := 2;
for k := 1 to 3 do
s := s * s;
writeln(s);
end.

Введите ответ:
Вопрос № 6

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел k, i
k := 4
нц для i от 1 до 3
k := i + 2 * k
кц
вывод k
кон

Бейсик
DIM k, i AS INTEGER
k = 4
FOR i = 1 TO 3
k = i + 2 * k
NEXT i
PRINT k

Паскаль
var k, i: integer;
begin
k := 4;
for i := 1 to 3 do
k := i + 2 * k;
writeln(k);
end.

Введите ответ:
Вопрос № 7

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел s, n
s := 5

s := s + (n-1)
кц
вывод s
кон

Бейсик
DIM n, s AS INTEGER
s = 5
FOR n = 2 TO 4
s = s + (n-1)
NEXT n
PRINT s

Паскаль
var s,n: integer;
begin
s := 5;
for n := 2 to 4 do
s := s + (n-1);
writeln(s);
end.

Введите ответ:
Вопрос № 8

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел s, k
s := 1
нц для k от 3 до 0
шаг ?1
s := s * 3
кц
вывод s
кон

Бейсик
DIM k, s AS INTEGER
s = 1
FOR k = 3 TO 0
STEP ?1
s = s * 3
NEXT k
PRINT s

Паскаль
var s,k: integer;
begin
s := 1;
for k := 3 downto 0 do
s := s * 3;
writeln(s);
end.

Введите ответ:
Вопрос № 9

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел s, k
s := 50
нц для k от 0 до 8
s := s ? 4
кц
вывод s
кон

Бейсик
DIM k, s AS INTEGER
s = 50
FOR k = 0 TO 8
s = s ? 4
NEXT k
PRINT s

Паскаль
var s,k: integer;
begin
s := 50;
for k := 0 to 8 do
s := s ? 4;
writeln(s);
end.

Введите ответ:
Вопрос № 10

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык
алг
нач
цел f, n
f := 4;
f := f*3;
нц для n от 1 до 4
f := f + n
кц
вывод f
кон

Бейсик
DIM f, n AS INTEGER
f = 4
f = f*3
FOR n = 1 TO 4
f = f + n
NEXT n
PRINT f

Паскаль
var f, n: integer;
begin
f := 4;
f := f*3;
for n := 1 to 4 do
f := f + n;
writeln(f);
end.

Введите ответ:
.

© 2018–2019    Звездина Вера Алексеевна

SSL